summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-02 15:34:59 +0000
committerSteven Barth <steven@midlink.org>2008-06-02 15:34:59 +0000
commita6fa1e08336e16d487f3c0913ea07a8bb2b345a7 (patch)
treefbe3d3b556834a6373af0763011fcd0284bd82ae
parent0ad9e29e5e05f679dac91e37026c05742c1491fc (diff)
fix symlink creation
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ec0d76a62..0e09682ae 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,8 @@ luahost: luabuild hostcopy
hostcopy:
mkdir -p host
for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
- ln -sf .$(LUCI_INSTALLDIR) host/luci
+ rm -f host/luci
+ ln -s .$(LUCI_INSTALLDIR) host/luci
run: host
./host/usr/bin/boa -c ./host/etc/boa -d