summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-07-20 07:30:35 +0200
committerGitHub <noreply@github.com>2018-07-20 07:30:35 +0200
commit7cf295de2c8f040471ac0a1a72cba3880789ac4b (patch)
treeaf909b4493c6fcb38d0069ca24b9a028618ca506
parentf7cf8ff6c3dedc45049e8390f209531d99cf4757 (diff)
parent3471e37b3b73a79409668b5a05f958f1eb933ea8 (diff)
Merge pull request #1969 from stangri/luci-app-simple-adblock
luci-app-simple-adblock: change style of button to important
-rw-r--r--applications/luci-app-simple-adblock/Makefile2
-rw-r--r--applications/luci-app-simple-adblock/luasrc/model/cbi/simple-adblock.lua6
2 files changed, 4 insertions, 4 deletions
diff --git a/applications/luci-app-simple-adblock/Makefile b/applications/luci-app-simple-adblock/Makefile
index fa98f8e0f..8d2055829 100644
--- a/applications/luci-app-simple-adblock/Makefile
+++ b/applications/luci-app-simple-adblock/Makefile
@@ -10,7 +10,7 @@ LUCI_TITLE:=Simple Adblock Web UI
LUCI_DESCRIPTION:=Provides Web UI for simple-adblock service.
LUCI_DEPENDS:=+luci-mod-admin-full +simple-adblock
LUCI_PKGARCH:=all
-PKG_RELEASE:=14
+PKG_RELEASE:=15
include ../../luci.mk
diff --git a/applications/luci-app-simple-adblock/luasrc/model/cbi/simple-adblock.lua b/applications/luci-app-simple-adblock/luasrc/model/cbi/simple-adblock.lua
index aa62ff56c..4dbb21c6e 100644
--- a/applications/luci-app-simple-adblock/luasrc/model/cbi/simple-adblock.lua
+++ b/applications/luci-app-simple-adblock/luasrc/model/cbi/simple-adblock.lua
@@ -24,7 +24,7 @@ else
if enabledFlag ~= "1" or status:match("Stopped") then
en.title = translate("Service is disabled/stopped")
en.inputtitle = translate("Enable/Start")
- en.inputstyle = "apply"
+ en.inputstyle = "apply important"
if nixio.fs.access("/var/simple-adblock.cache") then
ds = h:option(DummyValue, "_dummy", translate("Service Status"))
ds.template = "simple-adblock/status"
@@ -33,7 +33,7 @@ else
else
en.title = translate("Service is enabled/started")
en.inputtitle = translate("Stop/Disable")
- en.inputstyle = "reset"
+ en.inputstyle = "reset important"
ds = h:option(DummyValue, "_dummy", translate("Service Status"))
ds.template = "simple-adblock/status"
ds.value = status
@@ -41,7 +41,7 @@ else
reload = h:option(Button, "__reload")
reload.title = translate("Service started with error")
reload.inputtitle = translate("Reload")
- reload.inputstyle = "apply"
+ reload.inputstyle = "apply important"
function reload.write()
luci.sys.exec("/etc/init.d/simple-adblock reload")
luci.http.redirect(luci.dispatcher.build_url("admin/services/" .. packageName))