summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-07-06 18:42:02 +0300
committerGitHub <noreply@github.com>2018-07-06 18:42:02 +0300
commit885f993593d13cd7828e5f4b4b27a4b46d7918ab (patch)
treedacc9e6b4f686d97e4fe454885b3ae0279efa310
parent26d90f0c10907d5b8919aea3ccb01e95591ed038 (diff)
parent639bbc18276034ea7c2f7edc309acc961b19d1d2 (diff)
Merge pull request #1939 from Ansuel/luci-nginx
luci-nginx: fix nginx dependency
-rw-r--r--collections/luci-ssl-nginx/Makefile10
-rw-r--r--collections/luci-ssl-openssl-nginx/Makefile21
2 files changed, 8 insertions, 23 deletions
diff --git a/collections/luci-ssl-nginx/Makefile b/collections/luci-ssl-nginx/Makefile
index d7ff49a7a3..549c44af11 100644
--- a/collections/luci-ssl-nginx/Makefile
+++ b/collections/luci-ssl-nginx/Makefile
@@ -9,8 +9,14 @@ include $(TOPDIR)/rules.mk
LUCI_TYPE:=col
LUCI_BASENAME:=ssl
-LUCI_TITLE:=LuCI with HTTPS support (mbedTLS as SSL backend)
-LUCI_DEPENDS:=+luci-nginx +nginx-mod-luci-ssl +libustream-mbedtls +px5g
+LUCI_TITLE:=LuCI with HTTPS support on Nginx (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ OpenSSL cmd tools (openssl-util) are used by nginx for SSL key generation. \
+
+LUCI_DEPENDS:= \
+ +nginx-ssl +nginx-mod-luci-ssl +luci-mod-admin-full +luci-theme-bootstrap \
+ +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+ +rpcd-mod-rrdns +libustream-openssl +openssl-util
PKG_LICENSE:=Apache-2.0
diff --git a/collections/luci-ssl-openssl-nginx/Makefile b/collections/luci-ssl-openssl-nginx/Makefile
deleted file mode 100644
index 51096471e1..0000000000
--- a/collections/luci-ssl-openssl-nginx/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Copyright (C) 2016 The LuCI Team
-#
-# This is free software, licensed under the Apache License, Version 2.0 .
-#
-
-include $(TOPDIR)/rules.mk
-
-LUCI_TYPE:=col
-LUCI_BASENAME:=ssl-openssl
-
-LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
-LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
- OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
- instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
-
-LUCI_DEPENDS:=+luci-nginx +nginx-mod-luci-ssl +libustream-openssl +openssl-util
-
-include ../../luci.mk
-
-# call BuildPackage - OpenWrt buildroot signature