summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-23 00:20:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-23 00:20:39 +0000
commit61f22c5b3979f6c0796646968cded799bcf19c57 (patch)
tree118d826aed0d38ef0cfcb1f4b0debabb26bb1978
parent969b971d0dc99101004e08347ae8f2d73f685a88 (diff)
contrib/package: switch default TLS provider to CyaSSL
-rw-r--r--contrib/package/luci/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 7cdcb7a01..5cfab4c9c 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -275,7 +275,7 @@ endef
-NIXIO_TLS:=axtls
+NIXIO_TLS:=cyassl
define Package/luci-nixio
$(call Package/luci/libtemplate)
@@ -290,7 +290,7 @@ endef
define Package/luci-nixio/config
choice
prompt "TLS Provider"
- default PACKAGE_luci-nixio_axtls
+ default PACKAGE_luci-nixio_cyassl
config PACKAGE_luci-nixio_axtls
bool "Builtin (axTLS)"
@@ -305,6 +305,10 @@ define Package/luci-nixio/config
endchoice
endef
+ifneq ($(CONFIG_PACKAGE_luci-nixio_axtls),)
+ NIXIO_TLS:=axtls
+endif
+
ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
NIXIO_TLS:=openssl
endif