summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-30 20:49:23 +0000
committerSteven Barth <steven@midlink.org>2008-05-30 20:49:23 +0000
commit464f6ed4566f6711bf5a3fa28d780cb8d71c0014 (patch)
tree1de635328062054677e675c74b304802dba03885
parentd8ba05412c3bd76fead8c512a112a7bf230d2b8a (diff)
* Reintroduced compiling support
* Added switch for Production (compiled) / Debug (source) - Target to OpenWRT configuration menu
-rw-r--r--contrib/package/luci/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index e77c41e66..fc0e468ea 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -16,7 +16,6 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-# LUA_TARGET:=compile LUAC=$(BUILD_DIR_HOST)/lua/luac
LUA_TARGET:=source
PKG_SELECTED_MODULES:=
@@ -79,6 +78,24 @@ define Package/luci-core/install
$(call Package/luci/install/template,$(1),libs/core)
endef
+define Package/luci-core/config
+ choice
+ prompt "Build Target"
+ default PACKAGE_luci-core_compile
+
+ config PACKAGE_luci-core_compile
+ bool "Production"
+
+ config PACKAGE_luci-core_source
+ bool "Debug"
+
+ endchoice
+endef
+
+ifneq ($(CONFIG_PACKAGE_luci-core_compile),)
+ LUA_TARGET:=compile
+endif
+
### Libraries ###
define Package/luci-cbi