summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-05-14 21:10:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-05-14 21:10:40 +0000
commit4fbecc4874340a2e844a2deecdc49ea2cfa1f620 (patch)
treef2149a323620479f581601ccddb76ae8d67ae2af
parent6948b6bc70456ab137463dc1b8520e6abc9480e3 (diff)
build: add "po" target to Makefile
-rw-r--r--Makefile6
-rwxr-xr-xbuild/i18n-lua2po.pl4
2 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a45d39e892..4abb358b21 100644
--- a/Makefile
+++ b/Makefile
@@ -66,6 +66,12 @@ uvldocs: hostenv
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
"build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+po:
+ for L in $${LANGUAGE:-$$(find i18n/ -path 'i18n/*/luasrc/i18n/*' -name 'default.*.lua' | \
+ sed -e 's!.*/default\.\(.*\)\.lua!\1!')}; do \
+ build/i18n-lua2po.pl . $(realpath host)/po $$L; \
+ done
+
run:
# make run is deprecated #
# Please use: #
diff --git a/build/i18n-lua2po.pl b/build/i18n-lua2po.pl
index a9bc3b4f64..4905bb4b1a 100755
--- a/build/i18n-lua2po.pl
+++ b/build/i18n-lua2po.pl
@@ -73,9 +73,9 @@ if( open F, "find . -path '*/luasrc/i18n/*' -name '*.$master_lang.lua' |" )
printf "Generating %-40s ",
"$target_dir/$basename.$ext";
- printf T "# %s.%s.po\n# generated from %s\n\nmsgid \"\"\n" .
+ printf T "# %s.%s\n# generated from %s\n\nmsgid \"\"\n" .
"msgstr \"Content-Type: text/plain; charset=UTF-8\"\n\n",
- $basename, $target_lang, $file;
+ $basename, $ext, $file;
while( chomp( my $entry = readline L ) )
{