summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2025-05-01 22:39:32 +0200
committerMikael Magnusson <mikma@users.sourceforge.net>2025-05-01 23:05:32 +0200
commit44c87edb767d77e613e3e7bdb63bc3596733fdee (patch)
treeb11f72c86b1c9ddd517bf20b4625cec611c9b0e2 /debian/rules
parentf7faf0594b1403445976c53b6b92473bb3f64de3 (diff)
add debian packagedebian/latest
Signed-off-by: Mikael Magnusson <mikma@users.sourceforge.net>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..07ca69b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+# See debhelper(7) (uncomment to enable).
+# Output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+export PYBUILD_NAME=ioctl
+
+%:
+ dh $@ --buildsystem=pybuild
+
+
+# If you need to rebuild the Sphinx documentation:
+# Add sphinxdoc to the dh --with line.
+#
+# And uncomment the following lines.
+#execute_after_dh_auto_build-indep: export http_proxy=127.0.0.1:9
+#execute_after_dh_auto_build-indep: export https_proxy=127.0.0.1:9
+#execute_after_dh_auto_build-indep:
+# PYTHONPATH=. python3 -m sphinx -N -bhtml \
+# docs/ build/html # HTML generator
+# PYTHONPATH=. python3 -m sphinx -N -bman \
+# docs/ build/man # Manpage generator