diff options
-rwxr-xr-x | build.sh | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -74,6 +74,13 @@ build_procd() { ln -s $(pwd)/dl/procd sdk/package/lxd-procd fi make -C sdk package/lxd-procd/compile + local date=$(grep PKG_SOURCE_DATE:= dl/procd/Makefile | cut -d '=' -f 2) + local version=$(grep PKG_SOURCE_VERSION:= dl/procd/Makefile | cut -d '=' -f 2 | cut -b '1-8') + local release=$(grep PKG_RELEASE:= dl/procd/Makefile | cut -d '=' -f 2) + local procd_ipkg="sdk/bin/targets/${arch}/${subarch}/packages/procd_${date}-${version}-${release}_${arch}_${subarch}.ipk" + test -e bin/packages/ || mkdir bin/packages/ + ln -sf ../../$procd_ipkg bin/packages/ +} } build_tarball() { |