diff options
author | Mikael Magnusson <mikma@users.sourceforge.net> | 2018-02-26 13:09:01 +0100 |
---|---|---|
committer | Mikael Magnusson <mikma@users.sourceforge.net> | 2018-02-26 13:09:01 +0100 |
commit | 1d5d65105205685dc06ec2c59d44ac3e0f0683aa (patch) | |
tree | aac8ebd313db803117206577094883898b712859 | |
parent | df3627a25bd24e2ece8d8d2314e282a969e58767 (diff) |
Link procd package to bin/packages/
-rwxr-xr-x | build.sh | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -74,6 +74,13 @@ build_procd() { ln -s $(pwd)/dl/procd sdk/package/lxd-procd fi make -C sdk package/lxd-procd/compile + local date=$(grep PKG_SOURCE_DATE:= dl/procd/Makefile | cut -d '=' -f 2) + local version=$(grep PKG_SOURCE_VERSION:= dl/procd/Makefile | cut -d '=' -f 2 | cut -b '1-8') + local release=$(grep PKG_RELEASE:= dl/procd/Makefile | cut -d '=' -f 2) + local procd_ipkg="sdk/bin/targets/${arch}/${subarch}/packages/procd_${date}-${version}-${release}_${arch}_${subarch}.ipk" + test -e bin/packages/ || mkdir bin/packages/ + ln -sf ../../$procd_ipkg bin/packages/ +} } build_tarball() { |