summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7199d7c..bbbfd02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,6 +323,21 @@ AC_ARG_ENABLE(shadow,
]
)
+AC_ARG_ENABLE(epka,
+ [ --enable-epka Enable support for External Public Key Authentication plug-in],
+ [
+ AC_DEFINE(DROPBEAR_EPKA, 1, External Public Key Authentication)
+ AC_MSG_NOTICE(Enabling support for External Public Key Authentication)
+ DROPBEAR_EPKA=1
+ ],
+ [
+ AC_DEFINE(DROPBEAR_EPKA, 0, External Public Key Authentication)
+ DROPBEAR_EPKA=0
+ ]
+
+)
+AC_SUBST(DROPBEAR_EPKA)
+
AC_ARG_ENABLE(fuzz,
[ --enable-fuzz Build fuzzing. Not recommended for deployment.],
[