summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f92328..6a61d82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,12 @@ AC_PREREQ(2.59)
AC_INIT
AC_CONFIG_SRCDIR(buffer.c)
+# Record which revision is being built
+if which -s hg && test -d "$srcdir/.hg"; then
+ hgrev=`hg id -i -R "$srcdir"`
+ echo "Source directory Mercurial base revision $hgrev"
+fi
+
# Checks for programs.
AC_PROG_CC