summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2017-06-23 21:31:49 +0800
committerMatt Johnston <matt@ucc.asn.au>2017-06-23 21:31:49 +0800
commitb967dc1fa506b2e810a6eb370492bab955e46e14 (patch)
tree5f2a196607120cef6d053b52c80182acad206261 /configure.ac
parent2cbe70ba344b2af273aab8d1a4e228faa0934751 (diff)
parentaf2caaab7279b14ea2ed92726086c9f8f2935e75 (diff)
merge
--HG-- branch : fuzz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e2ab814..e79b8c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ AC_PREREQ(2.59)
AC_INIT
AC_CONFIG_SRCDIR(buffer.c)
-OLDCFLAGS=$CFLAGS
+OLDCFLAGS="$CFLAGS"
# Checks for programs.
AC_PROG_CC
AC_PROG_MAKE_SET
@@ -24,6 +24,17 @@ if test -z "$OLDCFLAGS" && test "$GCC" = "yes"; then
CFLAGS="-Os -W -Wall -Wno-pointer-sign"
fi
+AC_MSG_CHECKING([if compiler '$CC' supports -fno-strict-overflow])
+OLDCFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fno-strict-overflow"
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ CFLAGS=$OLDCFLAGS
+ ]
+ )
+
# large file support is useful for scp
AC_SYS_LARGEFILE