summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2017-06-23 21:31:25 +0800
committerMatt Johnston <matt@ucc.asn.au>2017-06-23 21:31:25 +0800
commitaf2caaab7279b14ea2ed92726086c9f8f2935e75 (patch)
treee626705d2d6bb92f3f83df452df9e95dfa356052 /configure.ac
parent169f41a43c6e7f98a1d0f3f62591a3cf527291fa (diff)
Compile with -fno-strict-overflow if possible.
Needed for curve25519-donna https://github.com/agl/curve25519-donna/issues/31
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 767bd05..1e4ea4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ AC_PREREQ(2.59)
AC_INIT
AC_CONFIG_SRCDIR(buffer.c)
-OLDCFLAGS=$CFLAGS
+OLDCFLAGS="$CFLAGS"
# Checks for programs.
AC_PROG_CC
AC_PROG_MAKE_SET
@@ -24,6 +24,17 @@ if test -z "$OLDCFLAGS" && test "$GCC" = "yes"; then
CFLAGS="-Os -W -Wall -Wno-pointer-sign"
fi
+AC_MSG_CHECKING([if compiler '$CC' supports -fno-strict-overflow])
+OLDCFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fno-strict-overflow"
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ CFLAGS=$OLDCFLAGS
+ ]
+ )
+
# large file support is useful for scp
AC_SYS_LARGEFILE