summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2018-02-28 23:42:57 +0800
committerMatt Johnston <matt@ucc.asn.au>2018-02-28 23:42:57 +0800
commita0ab5e86b504bd9d21ecd402387b605969fe98a2 (patch)
tree23f73ac8712e304b62fe488a246755fcfff95f42 /configure.ac
parenta1dcaf82a0a626d4c42fdd75388481bab90360ad (diff)
more portable for `which hg` test
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c485393..6621120 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@ AC_INIT
AC_CONFIG_SRCDIR(buffer.c)
# Record which revision is being built
-if which -s hg && test -d "$srcdir/.hg"; then
+if test -s "`which hg`" && test -d "$srcdir/.hg"; then
hgrev=`hg id -i -R "$srcdir"`
AC_MSG_NOTICE([Source directory Mercurial base revision $hgrev])
fi