summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2018-03-03 10:10:16 +0800
committerMatt Johnston <matt@ucc.asn.au>2018-03-03 10:10:16 +0800
commit8d0b48f16550c9bf3693b2fa683f21e8276b1b1a (patch)
tree274c38e70b52fea3c758917eb474722af6bddf4b /configure.ac
parentce1f9cdf7c27bb877d8efd3048af6e5ea513d09a (diff)
Fix CFLAGS for configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6621120..d1b2602 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,7 @@ if test -s "`which hg`" && test -d "$srcdir/.hg"; then
AC_MSG_NOTICE([Source directory Mercurial base revision $hgrev])
fi
+ORIGCFLAGS="$CFLAGS"
# Checks for programs.
AC_PROG_CC
@@ -35,7 +36,7 @@ AC_DEFUN(DB_TRYADDCFLAGS,
}])
# set compile flags prior to other tests
-if test -z "$OLDCFLAGS" && test "$GCC" = "yes"; then
+if test -z "$ORIGCFLAGS" && test "$GCC" = "yes"; then
AC_MSG_NOTICE(No \$CFLAGS set... using "-Os -W -Wall" for GCC)
CFLAGS="-Os -W -Wall"
fi