summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2020-05-28 22:50:41 +0800
committerMatt Johnston <matt@ucc.asn.au>2020-05-28 22:50:41 +0800
commit89e98a2f8382bcaab0e7ba04cb4050c9d62898a4 (patch)
treed0e2d836a78fc8ad73850bcca665914efbea15df /configure.ac
parent5027bc4db18a50aebd70bf4ae41f7702469c01ba (diff)
Use Linux getrandom() to ensure random device is initialised
Remove old code warning about random device being not ready, /dev/random isn't used by default anyway.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bcb6e4a..848c261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -370,7 +370,8 @@ AC_CHECK_HEADERS([netinet/in.h netinet/tcp.h \
crypt.h \
pty.h libutil.h libgen.h inttypes.h stropts.h utmp.h \
utmpx.h lastlog.h paths.h util.h netdb.h security/pam_appl.h \
- pam/pam_appl.h netinet/in_systm.h sys/uio.h linux/pkt_sched.h])
+ pam/pam_appl.h netinet/in_systm.h sys/uio.h linux/pkt_sched.h \
+ sys/random.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -526,7 +527,7 @@ AC_CHECK_FUNCS(clock_gettime)
AC_CHECK_HEADERS([mach/mach_time.h])
AC_CHECK_FUNCS(mach_absolute_time)
-AC_CHECK_FUNCS(explicit_bzero memset_s)
+AC_CHECK_FUNCS(explicit_bzero memset_s getrandom)
AC_ARG_ENABLE(bundled-libtom,
[ --enable-bundled-libtom Force using bundled libtomcrypt/libtommath even if a system version exists.