summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2021-03-04 21:03:02 +0800
committerMatt Johnston <matt@ucc.asn.au>2021-03-04 21:03:02 +0800
commit03481aba068e534063f58ffaa4e8c2c060fa6e14 (patch)
treeece330526fa74a31bc2f2c7c9387939c65753cc1 /configure.ac
parent8b0fdf8010969204a443e877868fca772d18f31c (diff)
Define _GNU_SOURCE properly, other header fixes
This lets -std=c89 build for gcc 8.4.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f552a8..83bb239 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,9 @@ DB_TRYADDCFLAGS([-Wno-pointer-sign])
AC_MSG_NOTICE([Checking if compiler '$CC' supports -fno-strict-overflow])
DB_TRYADDCFLAGS([-fno-strict-overflow])
+# needed for various extensions. define early before autoconf tests
+AC_DEFINE([_GNU_SOURCE], [], [Use GNU extensions if glibc])
+
STATIC=0
AC_ARG_ENABLE(static,
[ --enable-static Build static binaries],