summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2017-06-24 10:34:19 +0800
committerMatt Johnston <matt@ucc.asn.au>2017-06-24 10:34:19 +0800
commit9b6f7fc9af56a4339194df490ec44b0cc7c7f55f (patch)
treea1a80c4f02af6a8b4d8ec594b7b20fafaa57d832 /configure.ac
parent5ac4a710006d5d3d68af99a01e1845792db890ce (diff)
parent57690891ce1591d0f18b0604145eb9eb1c29183b (diff)
merge from main
--HG-- branch : fuzz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 958e1a6..ba7e8dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,15 @@ if test "$hardenbuild" -eq 1; then
LDFLAGS="$LDFLAGS $TESTFLAGS"
AC_LINK_IFELSE([AC_LANG_PROGRAM([])],
[AC_MSG_NOTICE([Setting $TESTFLAGS])],
- [AC_MSG_NOTICE([Not setting $TESTFLAGS]); LDFLAGS="$OLDLDFLAGS" ]
+ [
+ LDFLAGS="$OLDLDFLAGS"
+ TESTFLAGS="-pie"
+ LDFLAGS="$LDFLAGS $TESTFLAGS"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_NOTICE([Setting $TESTFLAGS])],
+ [AC_MSG_NOTICE([Not setting $TESTFLAGS]); LDFLAGS="$OLDLDFLAGS" ]
+ )
+ ]
)
# readonly elf relocation sections (relro)
OLDLDFLAGS="$LDFLAGS"