summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44184273..9a2e55e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,15 @@ test -z "$FLEX" && AC_MSG_ERROR([Flex is missing.])
test -z "$BISON" && AC_MSG_ERROR([Bison is missing.])
test -z "$M4" && AC_MSG_ERROR([M4 is missing.])
+AC_MSG_CHECKING([bison version])
+BIRD_CHECK_BISON_VERSION(BISON_VERSION)
+AC_MSG_RESULT([$BISON_VERSION])
+if test "$bird_bison_synclines" = yes; then
+ M4FLAGS="$M4FLAGS -s"
+fi
+
+AC_SUBST([M4FLAGS])
+
BIRD_CHECK_PROG_FLAVOR_GNU([$M4],
[],
[AC_MSG_ERROR([Provided M4 is not GNU M4.])]