summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac119
1 files changed, 49 insertions, 70 deletions
diff --git a/configure.ac b/configure.ac
index ca8d7690..de612ec2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,9 +9,8 @@ AC_CONFIG_AUX_DIR(tools)
AC_ARG_ENABLE(debug, [ --enable-debug enable internal debugging routines (default: disabled)],,enable_debug=no)
AC_ARG_ENABLE(memcheck, [ --enable-memcheck check memory allocations when debugging (default: enabled)],,enable_memcheck=yes)
AC_ARG_ENABLE(client, [ --enable-client enable building of BIRD client (default: enabled)],,enable_client=yes)
-AC_ARG_ENABLE(ipv6, [ --enable-ipv6 enable building of IPv6 version (default: disabled)],,enable_ipv6=no)
AC_ARG_ENABLE(pthreads, [ --enable-pthreads enable POSIX threads support (default: detect)],,enable_pthreads=try)
-AC_ARG_WITH(suffix, [ --with-suffix=STRING use specified suffix for BIRD files (default: 6 for IPv6 version)],[given_suffix="yes"])
+AC_ARG_ENABLE(libssh, [ --enable-libssh enable LibSSH support together with RPKI protocol (default: detect)],,enable_libssh=try)
AC_ARG_WITH(sysconfig, [ --with-sysconfig=FILE use specified BIRD system configuration file])
AC_ARG_WITH(protocols, [ --with-protocols=LIST include specified routing protocols (default: all)],,[with_protocols="all"])
AC_ARG_WITH(sysinclude, [ --with-sysinclude=PATH search for system includes on specified place])
@@ -25,46 +24,25 @@ AC_ARG_VAR([M4], [location of the M4 program])
if test "$srcdir" = . ; then
# Building in current directory => create obj directory holding all objects
objdir=obj
- mkdir -p obj
- srcdir_rel=..
- makefiles="Makefile:tools/Makefile-top.in obj/Makefile:tools/Makefile.in obj/Rules:tools/Rules.in"
- exedir=..
else
# Building in separate directory
objdir=.
- srcdir_rel=$srcdir
- makefiles="Makefile:tools/Makefile.in Rules:tools/Rules.in"
- exedir=.
fi
-case $srcdir_rel in
- /*) srcdir_rel_mf=$srcdir_rel ;;
- *) srcdir_rel_mf="\$(root-rel)$srcdir_rel" ;;
-esac
+
+exedir=.
+
AC_SUBST(objdir)
AC_SUBST(exedir)
-AC_SUBST(srcdir_rel_mf)
+AC_SUBST(srcdir)
AC_SUBST(runtimedir)
-if test "$enable_ipv6" = yes ; then
- ip=ipv6
- SUFFIX=6
- proto_radv=radv
-else
- ip=ipv4
- SUFFIX=""
-fi
-
-if test "$given_suffix" = yes ; then
- SUFFIX="$with_suffix"
-fi
-AC_SUBST(SUFFIX)
if test "$enable_debug" = yes ; then
- CONFIG_FILE="bird$SUFFIX.conf"
- CONTROL_SOCKET="bird$SUFFIX.ctl"
+ CONFIG_FILE="bird.conf"
+ CONTROL_SOCKET="bird.ctl"
else
- CONFIG_FILE="\$(sysconfdir)/bird$SUFFIX.conf"
- CONTROL_SOCKET="$runtimedir/bird$SUFFIX.ctl"
+ CONFIG_FILE="\$(sysconfdir)/bird.conf"
+ CONTROL_SOCKET="$runtimedir/bird.ctl"
fi
AC_SUBST(CONFIG_FILE)
AC_SUBST(CONTROL_SOCKET)
@@ -80,6 +58,7 @@ if test "$ac_test_CFLAGS" != set ; then
fi
AC_PROG_CC
+AC_PROG_CC_C99
if test -z "$GCC" ; then
AC_MSG_ERROR([This program requires the GNU C Compiler.])
fi
@@ -101,6 +80,20 @@ if test "$enable_pthreads" != no ; then
fi
fi
+if test "$enable_libssh" != no ; then
+ AC_CHECK_LIB(ssh, ssh_connect)
+ if test $ac_cv_lib_ssh_ssh_connect = yes ; then
+ proto_rpki=rpki
+ enable_libssh=yes
+ else
+ if test "$enable_libssh" = yes ; then
+ AC_MSG_ERROR([LibSSH not available.])
+ else
+ enable_libssh=no
+ fi
+ fi
+fi
+
if test "$bird_cflags_default" = yes ; then
BIRD_CHECK_GCC_OPTION(bird_cv_c_option_wno_pointer_sign, -Wno-pointer-sign, -Wall)
BIRD_CHECK_GCC_OPTION(bird_cv_c_option_wno_missing_init, -Wno-missing-field-initializers, -Wall -Wextra)
@@ -141,36 +134,21 @@ if test -n "$with_sysconfig" -a "$with_sysconfig" != no ; then
elif test -f sysconfig.h ; then
sysdesc=sysconfig
else
- case "$ip:$host_os" in
- ipv6:linux*) sysdesc=linux-v6
+ case "$host_os" in
+ linux*) sysdesc=linux
default_iproutedir="/etc/iproute2"
;;
- ipv4:linux*) sysdesc=linux
- default_iproutedir="/etc/iproute2"
+ freebsd*) sysdesc=bsd
;;
- ipv6:netbsd*) sysdesc=bsd-v6
- CPPFLAGS="$CPPFLAGS -I/usr/pkg/include"
- LDFLAGS="$LDFLAGS -L/usr/pkg/lib -R/usr/pkg/lib"
+ kfreebsd*) sysdesc=bsd
;;
- ipv4:netbsd*) sysdesc=bsd
+ netbsd*) sysdesc=bsd
CPPFLAGS="$CPPFLAGS -I/usr/pkg/include"
LDFLAGS="$LDFLAGS -L/usr/pkg/lib -R/usr/pkg/lib"
;;
- ipv6:freebsd*) sysdesc=bsd-v6
- ;;
- ipv4:freebsd*) sysdesc=bsd
- ;;
- ipv6:dragonfly*) sysdesc=bsd-v6
- ;;
- ipv4:dragonfly*) sysdesc=bsd
- ;;
- ipv6:kfreebsd*) sysdesc=bsd-v6
- ;;
- ipv4:kfreebsd*) sysdesc=bsd
- ;;
- ipv6:openbsd*) sysdesc=bsd-v6
+ openbsd*) sysdesc=bsd
;;
- ipv4:openbsd*) sysdesc=bsd
+ dragonfly*) sysdesc=bsd
;;
*) AC_MSG_ERROR([Cannot determine correct system configuration. Please use --with-sysconfig to set it manually.])
;;
@@ -186,7 +164,7 @@ sysname=`echo $sysdesc | sed 's/\.h$//'`
AC_DEFINE_UNQUOTED([SYSCONF_INCLUDE], ["$sysdesc"], [Which sysdep header to include])
AC_MSG_CHECKING([system-dependent directories])
-sysdep_dirs="`sed <$sysdesc '/^Link: /!d;s/^Link: \(.*\)$/\1/' | tr '\012' ' '` lib"
+sysdep_dirs="`sed <$sysdesc '/^Link: /!d;s/^Link: \(.*\)$/\1/' | tr '\012' ' '`"
AC_MSG_RESULT($sysdep_dirs)
AC_SUBST(sysdep_dirs)
@@ -199,10 +177,8 @@ fi
AC_SUBST(iproutedir)
-all_protocols="$proto_bfd bgp ospf pipe $proto_radv rip static"
-if test "$ip" = ipv6 ; then
- all_protocols="$all_protocols babel"
-fi
+all_protocols="$proto_bfd babel bgp ospf pipe radv rip $proto_rpki static"
+
all_protocols=`echo $all_protocols | sed 's/ /,/g'`
if test "$with_protocols" = all ; then
@@ -216,6 +192,7 @@ AH_TEMPLATE([CONFIG_OSPF], [OSPF protocol])
AH_TEMPLATE([CONFIG_PIPE], [Pipe protocol])
AH_TEMPLATE([CONFIG_RADV], [RAdv protocol])
AH_TEMPLATE([CONFIG_RIP], [RIP protocol])
+AH_TEMPLATE([CONFIG_RPKI], [RPKI protocol])
AH_TEMPLATE([CONFIG_STATIC], [Static protocol])
AC_MSG_CHECKING([protocols])
@@ -232,7 +209,7 @@ AC_MSG_RESULT(ok)
AC_SUBST(protocols)
case $sysdesc in
- */linux*|*/linux-v6*)
+ */linux*)
AC_CHECK_HEADER(linux/rtnetlink.h,,[AC_MSG_ERROR([Appropriate version of Linux kernel headers not found.])],[
#include <asm/types.h>
#include <sys/socket.h>
@@ -243,6 +220,9 @@ esac
AC_CHECK_HEADERS_ONCE([alloca.h syslog.h])
AC_CHECK_MEMBERS([struct sockaddr.sa_len], [], [], [#include <sys/socket.h>])
+AC_CHECK_HEADER([linux/lwtunnel.h], [AC_DEFINE([HAVE_LWTUNNEL], [1], [Define to 1 if you have the <linux/lwtunnel.h> header file.])])
+AC_CHECK_MEMBERS([struct rtvia.rtvia_family], [AC_DEFINE([HAVE_STRUCT_RTVIA], [1], [Define to 1 if you have rtvia structure.])],,[#include <linux/rtnetlink.h>])
+
AC_C_BIGENDIAN(
[AC_DEFINE([CPU_BIG_ENDIAN], [1], [Define to 1 if cpu is big endian])],
[AC_DEFINE([CPU_LITTLE_ENDIAN], [1], [Define to 1 if cpu is little endian])],
@@ -254,6 +234,9 @@ BIRD_CHECK_TIME_T
if test "$enable_debug" = yes ; then
AC_DEFINE([DEBUGGING], [1], [Define to 1 if debugging is enabled])
+ AC_CHECK_HEADER(execinfo.h, [AC_SEARCH_LIBS([backtrace, backtrace_symbols], [c execinfo], [AC_DEFINE([HAVE_EXECINFO_H], [1], [Define to 1 if you have the <execinfo.h> header file.])])])
+ LDFLAGS="$LDFLAGS -rdynamic"
+ CFLAGS="$CFLAGS -O0 -ggdb -g3 -gdwarf-4"
if test "$enable_memcheck" = yes ; then
AC_CHECK_LIB(dmalloc, dmalloc_debug)
if test $ac_cv_lib_dmalloc_dmalloc_debug != yes ; then
@@ -262,10 +245,13 @@ if test "$enable_debug" = yes ; then
fi
fi
-CLIENT=
+DAEMON_LIBS=
+AC_SUBST(DAEMON_LIBS)
+
+CLIENT=birdcl
CLIENT_LIBS=
if test "$enable_client" = yes ; then
- CLIENT=birdc
+ CLIENT="$CLIENT birdc"
AC_CHECK_LIB(history, add_history, CLIENT_LIBS="-lhistory")
AC_CHECK_LIB(ncurses, tgetent, USE_TERMCAP_LIB=-lncurses,
AC_CHECK_LIB(curses, tgetent, USE_TERMCAP_LIB=-lcurses,
@@ -283,17 +269,9 @@ AC_SUBST(CLIENT_LIBS)
mkdir -p $objdir/sysdep
AC_CONFIG_HEADERS([$objdir/sysdep/autoconf.h:sysdep/autoconf.h.in])
-AC_CONFIG_COMMANDS([merge],[[export CPP="$CPP"
-$srcdir/tools/mergedirs $srcdir $srcdir_rel $objdir $sysdep_dirs]],
- [[srcdir=$srcdir]
- [srcdir_rel=$srcdir_rel]
- [objdir=$objdir]
- [sysdep_dirs="$sysdep_dirs"]])
-AC_CONFIG_FILES($makefiles)
+AC_CONFIG_FILES(Makefile:Makefile.in)
AC_OUTPUT
-rm -f $objdir/sysdep/paths.h
-
AC_MSG_RESULT()
AC_MSG_RESULT([BIRD was configured with the following options:])
AC_MSG_RESULT([ Source directory: $srcdir])
@@ -304,4 +282,5 @@ AC_MSG_RESULT([ Debugging: $enable_debug])
AC_MSG_RESULT([ POSIX threads: $enable_pthreads])
AC_MSG_RESULT([ Routing protocols: $protocols])
AC_MSG_RESULT([ Client: $enable_client])
+
rm -f $objdir/.*-stamp