summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 68e68282..f73e6264 100644
--- a/configure.ac
+++ b/configure.ac
@@ -366,12 +366,6 @@ if test "$enable_client" = yes ; then
[$TINFO_LIBS]
)
- AC_SEARCH_LIBS([add_history], [history readline],
- [HISTORY_LIBS="$LIBS"; LIBS=""],
- [AC_MSG_ERROR([The client requires GNU Readline library. Either install the library or use --disable-client to compile without the client.])],
- [$TINFO_LIBS]
- )
-
AC_CHECK_LIB([readline], [rl_crlf],
[AC_DEFINE([HAVE_RL_CRLF], [1], [Define to 1 if you have rl_crlf()])],
[],
@@ -385,7 +379,7 @@ if test "$enable_client" = yes ; then
)
LIBS="$BASE_LIBS"
- CLIENT_LIBS="$HISTORY_LIBS $READLINE_LIBS $TINFO_LIBS"
+ CLIENT_LIBS="$READLINE_LIBS $TINFO_LIBS"
fi
AC_SUBST([CLIENT])
AC_SUBST([CLIENT_LIBS])