summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Zajicek <santiago@crfreenet.org>2014-02-07 11:46:01 +0100
committerOndrej Zajicek <santiago@crfreenet.org>2014-02-07 11:46:01 +0100
commit9ae0f4b78c5e3619ee19969c052c863bf96be6d9 (patch)
tree531e51285b59e9fbe0d2dfac99bd3bda435a6cbc /configure.in
parent5c200e0a4d26d183e04fda43de16340521002c40 (diff)
Fixes autoconf check for ncurses.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5af574a5..09e29dc2 100644
--- a/configure.in
+++ b/configure.in
@@ -269,8 +269,9 @@ if test "$enable_client" = yes ; then
AC_CHECK_LIB(ncurses, tgetent, USE_TERMCAP_LIB=-lncurses,
AC_CHECK_LIB(curses, tgetent, USE_TERMCAP_LIB=-lcurses,
AC_CHECK_LIB(tinfow, tgetent, USE_TERMCAP_LIB=-ltinfow,
- AC_CHECK_LIB(tinfo, tgetent, USE_TERMCAP_LIB=-ltinfo
- AC_CHECK_LIB(termcap, tgetent, USE_TERMCAP_LIB=-ltermcap)))))
+ AC_CHECK_LIB(tinfo, tgetent, USE_TERMCAP_LIB=-ltinfo,
+ AC_CHECK_LIB(termcap, tgetent, USE_TERMCAP_LIB=-ltermcap,
+ AC_MSG_ERROR([[The client requires ncurses library. Either install the library or use --disable-client to compile without the client.]]))))))
AC_CHECK_LIB(readline, rl_callback_read_char, CLIENT_LIBS="-lreadline $CLIENT_LIBS $USE_TERMCAP_LIB",
AC_MSG_ERROR([[The client requires GNU readline library 2.1 or newer. Either install the library or use --disable-client to compile without the client.]]), $USE_TERMCAP_LIB)
AC_CHECK_LIB(readline, rl_crlf, AC_DEFINE(HAVE_RL_CRLF),,$USE_TERMCAP_LIB)