summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2015-12-20 19:47:36 +0100
committerOndrej Zajicek (work) <santiago@crfreenet.org>2015-12-20 19:47:36 +0100
commitd549b83fc2f66b4c5e15e158409442993a2d62c4 (patch)
tree17b428cfabd94d679307c47d315dc9a5e3911d32 /configure.in
parent0f7d5b1a889142cdcda0546d8adcc76de465ffb8 (diff)
Delete ipv6 option from configure
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in58
1 files changed, 15 insertions, 43 deletions
diff --git a/configure.in b/configure.in
index dd1ff7a5..6bee4e0c 100644
--- a/configure.in
+++ b/configure.in
@@ -9,9 +9,7 @@ AC_CONFIG_AUX_DIR(tools)
AC_ARG_ENABLE(debug, [ --enable-debug enable internal debugging routines (default: disabled)],,enable_debug=no)
AC_ARG_ENABLE(memcheck, [ --enable-memcheck check memory allocations when debugging (default: enabled)],,enable_memcheck=yes)
AC_ARG_ENABLE(client, [ --enable-client enable building of BIRD client (default: enabled)],,enable_client=yes)
-AC_ARG_ENABLE(ipv6, [ --enable-ipv6 enable building of IPv6 version (default: disabled)],,enable_ipv6=no)
AC_ARG_ENABLE(pthreads, [ --enable-pthreads enable POSIX threads support (default: detect)],,enable_pthreads=try)
-AC_ARG_WITH(suffix, [ --with-suffix=STRING use specified suffix for BIRD files (default: 6 for IPv6 version)],[given_suffix="yes"])
AC_ARG_WITH(sysconfig, [ --with-sysconfig=FILE use specified BIRD system configuration file])
AC_ARG_WITH(protocols, [ --with-protocols=LIST include specified routing protocols (default: all)],,[with_protocols="all"])
AC_ARG_WITH(sysinclude, [ --with-sysinclude=PATH search for system includes on specified place])
@@ -45,26 +43,13 @@ AC_SUBST(exedir)
AC_SUBST(srcdir_rel_mf)
AC_SUBST(runtimedir)
-if test "$enable_ipv6" = yes ; then
- ip=ipv6
- SUFFIX=6
- proto_radv=radv
-else
- ip=ipv4
- SUFFIX=""
-fi
-
-if test "$given_suffix" = yes ; then
- SUFFIX="$with_suffix"
-fi
-AC_SUBST(SUFFIX)
if test "$enable_debug" = yes ; then
- CONFIG_FILE="bird$SUFFIX.conf"
- CONTROL_SOCKET="bird$SUFFIX.ctl"
+ CONFIG_FILE="bird.conf"
+ CONTROL_SOCKET="bird.ctl"
else
- CONFIG_FILE="\$(sysconfdir)/bird$SUFFIX.conf"
- CONTROL_SOCKET="$runtimedir/bird$SUFFIX.ctl"
+ CONFIG_FILE="\$(sysconfdir)/bird.conf"
+ CONTROL_SOCKET="$runtimedir/bird.ctl"
fi
AC_SUBST(CONFIG_FILE)
AC_SUBST(CONTROL_SOCKET)
@@ -147,36 +132,21 @@ if test -n "$with_sysconfig" -a "$with_sysconfig" != no ; then
elif test -f sysconfig.h ; then
sysdesc=sysconfig
else
- case "$ip:$host_os" in
- ipv6:linux*) sysdesc=linux-v6
+ case "$host_os" in
+ linux*) sysdesc=linux
default_iproutedir="/etc/iproute2"
;;
- ipv4:linux*) sysdesc=linux
- default_iproutedir="/etc/iproute2"
+ freebsd*) sysdesc=bsd
;;
- ipv6:netbsd*) sysdesc=bsd-v6
- CPPFLAGS="$CPPFLAGS -I/usr/pkg/include"
- LDFLAGS="$LDFLAGS -L/usr/pkg/lib -R/usr/pkg/lib"
+ kfreebsd*) sysdesc=bsd
;;
- ipv4:netbsd*) sysdesc=bsd
+ netbsd*) sysdesc=bsd
CPPFLAGS="$CPPFLAGS -I/usr/pkg/include"
LDFLAGS="$LDFLAGS -L/usr/pkg/lib -R/usr/pkg/lib"
;;
- ipv6:freebsd*) sysdesc=bsd-v6
+ openbsd*) sysdesc=bsd
;;
- ipv4:freebsd*) sysdesc=bsd
- ;;
- ipv6:dragonfly*) sysdesc=bsd-v6
- ;;
- ipv4:dragonfly*) sysdesc=bsd
- ;;
- ipv6:kfreebsd*) sysdesc=bsd-v6
- ;;
- ipv4:kfreebsd*) sysdesc=bsd
- ;;
- ipv6:openbsd*) sysdesc=bsd-v6
- ;;
- ipv4:openbsd*) sysdesc=bsd
+ dragonfly*) sysdesc=bsd
;;
*) AC_MSG_ERROR([Cannot determine correct system configuration. Please use --with-sysconfig to set it manually.])
;;
@@ -205,7 +175,9 @@ fi
AC_SUBST(iproutedir)
-all_protocols="$proto_bfd ospf pipe $proto_radv rip static"
+# all_protocols="$proto_bfd bgp ospf pipe radv rip static"
+all_protocols="$proto_bfd ospf pipe radv rip static"
+
all_protocols=`echo $all_protocols | sed 's/ /,/g'`
if test "$with_protocols" = all ; then
@@ -226,7 +198,7 @@ AC_MSG_RESULT(ok)
AC_SUBST(protocols)
case $sysdesc in
- */linux*|*/linux-v6*)
+ */linux*)
AC_CHECK_HEADER(linux/rtnetlink.h,,[AC_MSG_ERROR([Appropriate version of Linux kernel headers not found.])],[
#include <asm/types.h>
#include <sys/socket.h>