summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2018-12-04 16:55:25 +0100
committerOndrej Zajicek (work) <santiago@crfreenet.org>2018-12-04 16:55:25 +0100
commit3fda08e40532245ba69e14cdac0623a138b939f9 (patch)
tree0332e47c73ab22c92df09518de90fefa89453b2a /configure.ac
parent0642fb4d456fe12e1bbeb2ffc2149433f228c02e (diff)
Unix: Change debugging options
The old behavior was that enabling debugging did many nontrivial changes in BIRD behavior. The patch changes it that these changes are generally independent. Compiling with --enable-debug now just enables compile-time debug macros, but do not automatically activate debug mode (-d) nor local mode (-l). Debug mode with output to file (-D) do not force foreground mode (-f), therefore there is no need for backgroud option (-b), which is removed. Also fixes a bug when the default log target in -D mode was stderr instead of given debug file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7abf88c8..ae2710f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,15 +85,10 @@ AC_SUBST([srcdir])
AS_IF([test -z "${runstatedir}"], [runstatedir='${localstatedir}/run'])
AC_SUBST([runstatedir])
-
-if test "$enable_debug" = yes ; then
- CONFIG_FILE="bird.conf"
- CONTROL_SOCKET="bird.ctl"
-else
- CONFIG_FILE="\$(sysconfdir)/bird.conf"
- CONTROL_SOCKET="\$(runstatedir)/bird.ctl"
-fi
+CONFIG_FILE="\$(sysconfdir)/bird.conf"
AC_SUBST([CONFIG_FILE])
+
+CONTROL_SOCKET="\$(runstatedir)/bird.ctl"
AC_SUBST([CONTROL_SOCKET])
AC_SEARCH_LIBS([clock_gettime], [rt posix4],