summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaria Matejka <mq@ucw.cz>2022-05-30 16:48:17 +0200
committerMaria Matejka <mq@ucw.cz>2022-05-30 16:48:17 +0200
commitb7e2edd4419fecb09b8690f8731e172f0c24789c (patch)
tree41c80ab4b0d524ff34e207bf15e8d79191276a2c /configure.ac
parentd7bec897ab772cdccce10b296d4efd48d9181297 (diff)
parent1d309c4ce6e95b68c64a8f007f6dd2f1830a5707 (diff)
Merge commit '1d309c4ce6e95b68c64a8f007f6dd2f1830a5707' into haugesund
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64181d29..321bed95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,13 @@ AC_C_BIGENDIAN(
[AC_MSG_ERROR([Cannot determine CPU endianity.])]
)
+BIRD_CHECK_POINTER_ALIGNMENT
+if test "$bird_cv_pointer_alignment" = "unknown" ; then
+ AC_MSG_ERROR([Couldn't determine pointer alignment])
+else
+ AC_DEFINE_UNQUOTED([CPU_POINTER_ALIGNMENT], [$bird_cv_pointer_alignment], [Pointer alignment for macro usage])
+fi
+
BIRD_CHECK_ANDROID_GLOB
if test "$bird_cv_lib_glob" = no ; then
AC_MSG_ERROR([glob.h not found.])