summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2018-07-28 15:50:30 +0200
committerOndrej Zajicek (work) <santiago@crfreenet.org>2018-07-28 15:52:19 +0200
commit3140c8b2ca48263da1a1f12b478031dc4b572db7 (patch)
tree3b2bf834075b2545ce67c66812ae2b60ca1d894e /configure.ac
parentaa2ec912f5a557f340a633e95b9fbf2ad7937edd (diff)
Move FreeBSD CFLAGS and LDFLAGS to configure
Backport of commit 09c1e370b3084f7acb7c3777427670a69945368a.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2c136526..44382e4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,9 +216,13 @@ else
;;
ipv6:freebsd*)
sysdesc=bsd-v6
+ CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ LDFLAGS="$LDFLAGS -L/usr/local/lib"
;;
ipv4:freebsd*)
sysdesc=bsd
+ CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ LDFLAGS="$LDFLAGS -L/usr/local/lib"
;;
ipv6:dragonfly*)
sysdesc=bsd-v6
@@ -419,4 +423,5 @@ AC_MSG_RESULT([ Debugging: $enable_debug])
AC_MSG_RESULT([ POSIX threads: $enable_pthreads])
AC_MSG_RESULT([ Routing protocols: $protocols])
AC_MSG_RESULT([ Client: $enable_client])
-rm -f $objdir/.*-stamp \ No newline at end of file
+
+rm -f $objdir/.*-stamp