summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaria Matejka <mq@ucw.cz>2022-10-12 10:52:53 +0200
committerMaria Matejka <mq@ucw.cz>2022-10-12 11:01:38 +0200
commitf182771f96280115e839315d9d3e5aa7c9343d54 (patch)
tree51b7f28a22259189d4df8a9c820e155515f7542e /configure.ac
parent2d99f1277317040d05cca7b8f04b43a66f6fe643 (diff)
Fixed SSH known hosts checking with older versions of libssh
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 330add87..f942ec1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,6 +276,12 @@ if test "$enable_libssh" != no ; then
enable_libssh=no
fi
fi
+
+ AC_CHECK_LIB([ssh], [ssh_session_is_known_server], [ssh_old_server_validation_api=no], [ssh_old_server_validation_api=yes])
+
+ if test "$ssh_old_server_validation_api" = yes; then
+ AC_DEFINE([HAVE_SSH_OLD_SERVER_VALIDATION_API], [1], [Define to 1 if ssh_session_is_known_server isn't defined])
+ fi
fi
if test "$enable_mpls_kernel" != no ; then