summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2019-04-11 01:29:12 +0200
committerMikael Magnusson <mikma@users.sourceforge.net>2020-09-13 18:05:34 +0200
commit9d325e1d63869ff06878fa951fb963cbeea295eb (patch)
treef16c12e69f21ee0e44f8a7f32549e81183065880 /configure.ac
parent227de2b4df37bb1a2e16e331add6c973b99457d0 (diff)
Android: disable include patterns if glob is unsupported
Because of missing glob() in NDK platforms before 28
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3ec309bf..4b6c31cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -361,10 +361,11 @@ AC_C_BIGENDIAN(
)
BIRD_CHECK_ANDROID_GLOB
-if test "$bird_cv_lib_glob" = no ; then
- AC_MSG_ERROR([glob.h not found.])
-elif test "$bird_cv_lib_glob" != yes ; then
- LIBS="$LIBS $bird_cv_lib_glob"
+if test "$bird_cv_lib_glob" != no ; then
+ AC_DEFINE([HAVE_GLOB], [1], [Define to 1 if you have glob()])
+ if test "$bird_cv_lib_glob" != yes ; then
+ LIBS="$LIBS $bird_cv_lib_glob"
+ fi
fi
BIRD_CHECK_ANDROID_LOG