summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2019-02-28 00:44:40 +0100
committerMikael Magnusson <mikma@users.sourceforge.net>2021-11-06 00:07:40 +0100
commit83446cbab725301e58dc41336c31c446996b4f28 (patch)
tree0442ddbba403669bd6d4eb1fcf9fafe80f66e825 /configure.ac
parent7eb6a44491501e3f403fde2e26affb673f5b5b11 (diff)
Wireguard: Initial commit
Wireguard: Debug Wireguard: Implement tunnel encode decode Wireguard: Add remote endpoint Wireguard: Refactor into peer and allowed ips functions Wireguard: Clean up config.Y Wireguard: Extended color community Wireguard: Allow multiple channels Wireguard: Add peer config settings Wireguard: Set up wireguard device Add private key and listen port items. Wireguard: Add peer list Wireguard: Move key conversion Wireguard: Use recursive tunnel encaps Wireguard: Add user space support Wireguard: Reinit wg device at shutdown Wireguard: Add channel hooks Wireguard: Implement copy_config Wireguard: Fixes Wireguard: Add tunnel_type config parameter Use 51820 (default wireguard port) as default tunnel type. Wireguard: Rename remote endpoint to tunnel endpoint Adopt to draft-ietf-idr-tunnel-encaps-13.txt by renaming emote endpoint to tunnel endpoint. Wireguard: Fix discarded const qualifiers Wireguard: Remove bgp include Wireguard: Generalize tunnel encapsulation Wireguard: Add struct tunnel_encap Wireguard: Remove wg peer on withdraw Wireguard: Refactor remove_allowed_ip Wireguard: Dump peers Wireguard: Fix duplicate allowedip entries Wireguard: Dump peers Wireguard: Don't add endpoint if not set Wireguard: Replace debug with DBG Wireguard: Replace log with WG_TRACE Wireguard: Refactor add_allowed_ip Wireguard: Don't replace peers Wireguard: Don't fix listen_port update Wireguard: Move wireguard formatting from tunnel_encaps library Wireguard: Change from eattr to adata in decode and format wireguard: support multiple TLVs Wireguard: use visitor in wireguard Wireguard: WIP add wireguard sub-TLV to parser Wireguard: update debug msg wireguard: register name Wireguard: WIP Wireguard: implement allowed_ips instead of allowed_ip Wireguard: fix free peer, and peer config syntax Wireguard: clean up Wireguard: change key options to bytestring Wireguard: Add EA_GET
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 64181d29..2c070b4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,7 +304,7 @@ if test "$enable_mpls_kernel" != no ; then
fi
fi
-all_protocols="$proto_bfd babel bgp mrt ospf perf pipe radv rip rpki static"
+all_protocols="$proto_bfd babel bgp mrt ospf perf pipe radv rip rpki static wireguard"
all_protocols=`echo $all_protocols | sed 's/ /,/g'`
@@ -322,6 +322,7 @@ AH_TEMPLATE([CONFIG_RADV], [RAdv protocol])
AH_TEMPLATE([CONFIG_RIP], [RIP protocol])
AH_TEMPLATE([CONFIG_RPKI], [RPKI protocol])
AH_TEMPLATE([CONFIG_STATIC], [Static protocol])
+AH_TEMPLATE([CONFIG_WIREGUARD], [Wireguard protocol])
AC_MSG_CHECKING([protocols])
protocols=`echo "$with_protocols" | sed 's/,/ /g'`