summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2019-04-11 01:29:12 +0200
committerMikael Magnusson <mikma@users.sourceforge.net>2020-05-08 21:40:34 +0200
commite0cb9c65b837ad5d725761505049755db0112b1c (patch)
tree59b60addf885de2663f23601c93dfd47e0801fd9 /configure.ac
parent04fbc0408da33ed6041bf92caaa82b25bcbf6601 (diff)
Android: disable include patterns if glob is unsupported
Because of missing glob() in NDK platforms before 28
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c20c4e29..011cdab8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,10 +364,11 @@ AC_C_BIGENDIAN(
)
BIRD_CHECK_ANDROID_GLOB
-if test "$bird_cv_lib_glob" = no ; then
- AC_MSG_ERROR([glob.h not found.])
-elif test "$bird_cv_lib_glob" != yes ; then
- LIBS="$LIBS $bird_cv_lib_glob"
+if test "$bird_cv_lib_glob" != no ; then
+ AC_DEFINE([HAVE_GLOB], [1], [Define to 1 if you have glob()x])
+ if test "$bird_cv_lib_glob" != yes ; then
+ LIBS="$LIBS $bird_cv_lib_glob"
+ fi
fi
BIRD_CHECK_ANDROID_LOG