summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2019-04-11 01:28:40 +0200
committerMikael Magnusson <mikma@users.sourceforge.net>2020-05-08 21:40:34 +0200
commit04fbc0408da33ed6041bf92caaa82b25bcbf6601 (patch)
tree02f49dc2b88ada1d111e13a22723a6ff90f1a0de /configure.ac
parent5bfc70df013a16c4193622f6a5386c8cbbe882ae (diff)
Configure: support building as static library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ec309bf..c20c4e29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,7 @@ AC_ARG_WITH([iproutedir],
AC_ARG_VAR([FLEX], [location of the Flex program])
AC_ARG_VAR([BISON], [location of the Bison program])
AC_ARG_VAR([M4], [location of the M4 program])
+AC_ARG_VAR([AR], [location of the AR program])
if test "$enable_debug_expensive" = yes; then
enable_debug=yes
@@ -182,10 +183,12 @@ AC_PROG_RANLIB
AC_CHECK_PROG([FLEX], [flex], [flex])
AC_CHECK_PROG([BISON], [bison], [bison])
AC_CHECK_PROGS([M4], [gm4 m4])
+AC_CHECK_PROGS([AR], [ar])
test -z "$FLEX" && AC_MSG_ERROR([Flex is missing.])
test -z "$BISON" && AC_MSG_ERROR([Bison is missing.])
test -z "$M4" && AC_MSG_ERROR([M4 is missing.])
+test -z "$AR" && AC_MSG_ERROR([AR is missing.])
AC_MSG_CHECKING([bison version])
BIRD_CHECK_BISON_VERSION(BISON_VERSION)